RTX 4090 libgomp: TODO

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
bratinag
Newbie
Newbie
Posts: 9
Joined: Tue Sep 13, 2022 12:30 pm

RTX 4090 libgomp: TODO

#1 Post by bratinag » Fri Mar 29, 2024 7:50 am

Hi,
I'm trying to compile and run VASP 6.4.3 on our Nvidia RTX 4090 GPU. I am using the latest nvidia hpc-sdk 24.3. The computer has i9-12900F processor and runs Ubuntu 22.04.4 LTS. The fftw library was installed via apt install.

I was not able to compile VASP with hdf5 support. By disabling it in the makefile.include the compilation finishes without problems. However running:

Code: Select all

mpirun - np 1 vasp_std 
produces the following output

Code: Select all

running    1 mpi-ranks, with    1 threads/rank, on    1 nodes
 distrk:  each k-point on    1 cores,    1 groups

libgomp: TODO
--------------------------------------------------------------------------
Primary job  terminated normally, but 1 process returned
a non-zero exit code. Per user-direction, the job has been aborted.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpirun detected that one or more processes exited with non-zero status, thus causing
the job to be terminated. The first process to do so was:

  Process name: [[24861,1],0]
  Exit code:    1
 
The compilation of the code suggested in one of the previous posts

Code: Select all

program main
    implicit none
    #include "fftw3.f"
    integer, parameter :: N = 100
    double complex in, out
    dimension in(N), out(N)
    integer*8 plan
    call dfftw_plan_dft_1d(plan,N,in,out,FFTW_FORWARD,FFTW_ESTIMATE)
    call dfftw_execute_dft(plan, in, out)
    call dfftw_destroy_plan(plan)
end program main
using the command

Code: Select all

nvfortran test_v.f90  -I /usr/include -L /usr/lib/x86_64-linux-gnu -lfftw3
ends up with an error:

Code: Select all

NVFORTRAN-W-0025-Illegal character (#) - ignored (test_v.f90: 3)
  0 inform,   1 warnings,   0 severes, 0 fatal for main
The makefile.include is attached.

Regards.

Gvido
You do not have the required permissions to view the files attached to this post.

martin.schlipf
Global Moderator
Global Moderator
Posts: 495
Joined: Fri Nov 08, 2019 7:18 am

Re: RTX 4090 libgomp: TODO

#2 Post by martin.schlipf » Fri Mar 29, 2024 8:03 am

You can remove the # or rename the file to test_v.F90 to remove the warning. Since this is just a warning you should get a compiled output either way. Do you get an error when you run the executable? How about if you add the -lfftw3_omp that you have in your makefile.include?

bratinag
Newbie
Newbie
Posts: 9
Joined: Tue Sep 13, 2022 12:30 pm

Re: RTX 4090 libgomp: TODO

#3 Post by bratinag » Fri Mar 29, 2024 9:40 am

Update:

I followed precisely the procedure explained here https://implant.fs.cvut.cz/vasp-gpu-compilation/. VASP runs smoothly on the GPU now.

Gvido

martin.schlipf
Global Moderator
Global Moderator
Posts: 495
Joined: Fri Nov 08, 2019 7:18 am

Re: RTX 4090 libgomp: TODO

#4 Post by martin.schlipf » Fri Mar 29, 2024 2:42 pm

Okay, so you switched to the MKL FFTW implementation instead of the default ones you get with apt. Great that this fixes your issue.

Post Reply