error related to memory allocation on gpu with vasp/6.1.2 std calculations on Power9

questions related to VASP with GPU support (vasp.5.4.1, version released in Feb 2016)

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
mariella_ippolito1
Newbie
Newbie
Posts: 8
Joined: Wed Dec 04, 2019 12:42 pm

error related to memory allocation on gpu with vasp/6.1.2 std calculations on Power9

#1 Post by mariella_ippolito1 » Fri Nov 27, 2020 8:31 am

Dear Vasp support,
I'm experiencing some problems running a vasp std calculation on Power9 architecture with GPUs.
I obtain the following error
FATAL ERROR: data in PRESENT clause was not found on device 3: name=c host:0x4c00c100
file:/m100/prod/build/applications/vasp/6.1.2/hpc-sdk--2020--binary/BA_WORK/vasp-6.1.2/build/std/./fft3dsimple.F restride_r2q line:733

It seems to be related to memory allocation problems.
I tried with both 6.1.2 version than with older vasp version and the error is the same. I'm using the last hpc-sdk release and cuda/10.2.
The calculation run fine with the cpu version of the code.
This issue has been reported also to Nvidia.
I attach the input and output files.

Best regards,
Mariella
You do not have the required permissions to view the files attached to this post.

martin.schlipf
Global Moderator
Global Moderator
Posts: 164
Joined: Fri Nov 08, 2019 7:18 am

Re: error related to memory allocation on gpu with vasp/6.1.2 std calculations on Power9

#2 Post by martin.schlipf » Mon Nov 30, 2020 4:21 pm

Dear Mariella,
if the old GPU support does not work for you, please consider our new OpenAcc based GPU support
wiki/index.php/Makefile.include.linux_pgi_acc
The previous GPU implementation is unfortunately no longer actively maintained.

mariella_ippolito1
Newbie
Newbie
Posts: 8
Joined: Wed Dec 04, 2019 12:42 pm

Re: error related to memory allocation on gpu with vasp/6.1.2 std calculations on Power9

#3 Post by mariella_ippolito1 » Tue Jan 26, 2021 10:26 am

Dear Martin,
I'm using the OpenACC version of Vasp/6.1.2.
I still keep getting the same error related to memory allocation.
Could you please have a look at my input and output files (attached in the previous email) to help me figure out how to fix the problem?

Best regards,
Mariella

henrique_miranda
Global Moderator
Global Moderator
Posts: 235
Joined: Mon Nov 04, 2019 12:41 pm
Contact:

Re: error related to memory allocation on gpu with vasp/6.1.2 std calculations on Power9

#4 Post by henrique_miranda » Tue Jan 26, 2021 10:52 am

Dear Mariella,

In the latest VASP release 6.2.0 (available in the portal) new code paths were ported to GPU using OpenACC.
Some bug fixes were also made, it is possible that this issue might have already been solved.
Could you please try compiling and running the latest release?

If the problem persists in 6.2.0 please let us know so we can investigate it further.

Post Reply