SEGFAULT in HAMILTMU_TAU when using SCAN functional with EDDAV in vasp.5.4.4.pl2

Problems running VASP: crashes, internal errors, "wrong" results.

Moderators: Global Moderator, Moderator

Locked
Message
Author
craig_plaisance1
Newbie
Newbie
Posts: 1
Joined: Tue Dec 01, 2020 4:29 am

SEGFAULT in HAMILTMU_TAU when using SCAN functional with EDDAV in vasp.5.4.4.pl2

#1 Post by craig_plaisance1 » Fri Dec 11, 2020 2:04 am

I'm encountering a segfault when running the SCAN functional with the Davidson algorithm (IALGO=38) in vasp.5.4.4.pl2. It happens when VHAMIL gets called on line 952:
CALL VHAMIL(WDES1, WDES1%GRID, SV(1,ISP), W1(NP)%CR(1), CWORK1(1,NP))
Input and relevant output is attached. I can send POTCAR if needed - it was just the newest PBE POTCAR files

Here's the stack trace:

Image PC Routine Line Source
vasp_std 00000000014EE9FD Unknown Unknown Unknown
libpthread-2.12.s 00000031F640F7E0 Unknown Unknown Unknown
vasp_std 00000000006446E6 hamil_mp_hamiltmu 952 hamil.F
vasp_std 0000000000D1D7A3 david_mp_eddav_ 416 davidson.F
vasp_std 0000000000D84D01 elmin_ 424 electron.F
vasp_std 000000000137686C vamp_IP_electroni 4745 main.F
vasp_std 00000000013532CA MAIN__ 2792 main.F
vasp_std 000000000040EF5E Unknown Unknown Unknown
libc-2.12.so 00000031F601ED1D __libc_start_main Unknown Unknown
vasp_std 000000000040EE69 Unknown Unknown Unknown
forrtl: severe (174): SIGSEGV, segmentation fault occurred
You do not have the required permissions to view the files attached to this post.

martin.schlipf
Global Moderator
Global Moderator
Posts: 148
Joined: Fri Nov 08, 2019 7:18 am

Re: SEGFAULT in HAMILTMU_TAU when using SCAN functional with EDDAV in vasp.5.4.4.pl2

#2 Post by martin.schlipf » Mon Dec 14, 2020 10:53 am

I can reproduce this issue neither with vasp.5.4.4 nor with vasp.6.1.

Locked