XI_COULOMB error in a G0W0+SOC calculation

Problems running VASP: crashes, internal errors, "wrong" results.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
zcqsg27
Newbie
Newbie
Posts: 1
Joined: Mon May 09, 2016 12:38 pm
License Nr.: FA513901

XI_COULOMB error in a G0W0+SOC calculation

#1 Post by zcqsg27 » Mon May 09, 2016 12:57 pm

Hi,

I've encountered this error while trying to perform a GW calculation with LSORBIT turned on:

Code: Select all

internal error in VASP:  XI_COULOMB new method for calculating NQ is not correct
I've followed the VASP recipe for GW calculations more or less exactly, except with the addition of LSORBIT = .TRUE.

A pared down version of my INCAR that reproduces the error is:

Code: Select all

SYSTEM = GW density of states

start Parameters
  ICORELEVEL = 1
  NBANDS     = 352

parallelisation
  NCORE  = 12
  KPAR   = 8
  
electronic relaxation
  PREC     = Accurate
  ENMAX    = 350
  NELM     = 1
  EDIFF    = 1E-7
  LASPH    = .TRUE.
  ALGO     = GW0
  GGA      = PE
  PRECFOCK = Fast
  ENCUTGW  = 100

misc
  ISYM    = 0
  ISMEAR  = 0
  SIGMA   = 0.05
  NEDOS   = 1000
  LORBIT  = 11
  LVHAR   = .TRUE.
  LSORBIT = .TRUE.
  LOPTICS = .TRUE.
This G0W0 calculation is being run on preconverged WAVECAR and WAVEDIR files, as per the GW recipe.

What could be causing this error?

frabilloud
Newbie
Newbie
Posts: 1
Joined: Sat Jan 24, 2015 2:05 pm
License Nr.: 1894

Re: XI_COULOMB error in a G0W0+SOC calculation

#2 Post by frabilloud » Wed Mar 29, 2017 10:13 am

Hi,

I also encounter this error
internal error in VASP: XI_COULOMB new method for calculating NQ is not correct
while trying to do a GW0 calculation with VASP 5.4.1 version. I do not use LSORBIT.

Have you a solution for this problem ?

Thanks,
Franck

agtonner
Newbie
Newbie
Posts: 4
Joined: Wed Aug 25, 2010 12:39 pm
Location: Marburg, Germany

Re: XI_COULOMB error in a G0W0+SOC calculation

#3 Post by agtonner » Thu Apr 12, 2018 11:45 am

The problem also exists in 5.4.4

INCAR is as such:

Code: Select all

PREC = accurate
ENCUT = 350
EDIFF = 1E-07
EDIFFG = -1E-03
LREAL = Auto
ISYM = 0        
ISPIN = 1

IVDW = 12       #D3BJ

ISMEAR = 0
SIGMA = 0.05

LPLANE = .TRUE.

NWRITE = 2
LWAVE = F
LCHARG = F
LVTOT = F

NBANDS = 48
LOPTICS = .TRUE.
CSHIFT = 0.1
ALGO = GW0
LSPECTRAL = T
NOMEGA = 50
MAXMEM = 127000

shizhe1
Newbie
Newbie
Posts: 2
Joined: Sun Nov 17, 2019 4:19 pm

Re: XI_COULOMB error in a G0W0+SOC calculation

#4 Post by shizhe1 » Sun May 31, 2020 3:33 pm

Also encountered this error. Any suggestions? Thanks

shizhe1
Newbie
Newbie
Posts: 2
Joined: Sun Nov 17, 2019 4:19 pm

XI_COULOMB new method for calculating NQ is not correct

#5 Post by shizhe1 » Sun May 31, 2020 4:05 pm

I was doing GW calculation by explicitly writing out k-points in KPOINTS file using vasp5.4.4 and encountered this problem:
internal error in VASP: XI_COULOMB new method for calculating NQ is not correct

Is it ever possible to write out k-points in GW mode in VASP? I know I can do 4x4x4, etc.

ferenc_karsai
Global Moderator
Global Moderator
Posts: 99
Joined: Mon Nov 04, 2019 12:44 pm

Re: XI_COULOMB error in a G0W0+SOC calculation

#6 Post by ferenc_karsai » Tue Jun 09, 2020 6:41 am

Please upload your calculation according to the forum guidelines, then we can have a look at it properly.

Post Reply