BSE - WAVEDER cannot be found

Problems running VASP: crashes, internal errors, "wrong" results.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
pnikacevic
Newbie
Newbie
Posts: 9
Joined: Wed Aug 04, 2021 8:23 am

BSE - WAVEDER cannot be found

#1 Post by pnikacevic » Wed Nov 23, 2022 2:17 pm

I am having trouble with running a BSE calculation after I've done the G0W0 part. I put the WAVEDER from my DFT calculation into the folder, but I get the warning in the OUTCAR:

"The derivative of the wavefunctions with respect to k (WAVEDER) can not be found."

The calculation was left running for 2 hours on 12 nodes (48 cores each), and nothing significant happened during this time; "BSE setting up matrix" was the last relevant message in the output file.

I attach the input/output files for my BSE, GW, and (2nd) DFT step. WAVEDER is included in the BSE folder; job.sh is the job script, and slurm files are the stdout files. I do not attach the Wxxx.tmp files and such as they're too big; I just copied them from my GW folder to the BSE folder and ran the calc.

Any help with this? Thanks!
You do not have the required permissions to view the files attached to this post.

merzuk.kaltak
Administrator
Administrator
Posts: 190
Joined: Mon Sep 24, 2018 9:39 am

Re: BSE - WAVEDER cannot be found

#2 Post by merzuk.kaltak » Fri Nov 25, 2022 12:26 pm

Hello,

to run GW/BSE calculations for this system is a demanding task (with the quartic-scaling GW code).
As a general comment: Running jobs with a large number of MPI ranks is not always a good choice. Often, available memory per MPI rank is sometimes (more) important.
I suggest to run the job with less MPI ranks (cores) on each node to increase the available memory per MPI rank and to set MAXMEM in the INCAR.
Note latter is always given in MB per MPI rank.
For instance, running the job with 4 MPI ranks on each compute node with 120 GB of available RAM, the optimal value for MAXMEM would be 120* 1024 / 4 = 30720.

pnikacevic
Newbie
Newbie
Posts: 9
Joined: Wed Aug 04, 2021 8:23 am

Re: BSE - WAVEDER cannot be found

#3 Post by pnikacevic » Mon Nov 28, 2022 1:30 pm

Thanks for your reply!

I also tried a low-scaling algorithm but it apparently does not write Wxxx/WFULLxxxx.tmp files, so I couldn't do the BSE step afterwards

I will try the less MPI ranks approach; not sure if this will solve the WAVEDER not found problem though...

merzuk.kaltak
Administrator
Administrator
Posts: 190
Joined: Mon Sep 24, 2018 9:39 am

Re: BSE - WAVEDER cannot be found

#4 Post by merzuk.kaltak » Tue Nov 29, 2022 8:23 am

Writing the WFULL files with the low-scaling algorithm will be possible with version 6.4.0.
Is the WAVEDER file written in the DFT step?
If so, please make sure that the number of bands NBANDS in each calculation is consistent.
Also, could you please update to the most reason vasp version 6.3.2.

pnikacevic
Newbie
Newbie
Posts: 9
Joined: Wed Aug 04, 2021 8:23 am

Re: BSE - WAVEDER cannot be found

#5 Post by pnikacevic » Tue Nov 29, 2022 11:26 am

Ok, I'm looking forward to 6.4.0

I found the problem... My NBANDS in the INCAR was set to the same value, but in the OUTCAR it got modified to different values due to parallelization... I will try to make it work

Best,
Pavle

Post Reply