OTHER MPI ERROR while execution

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
pankaj_srivastava1
Newbie
Newbie
Posts: 1
Joined: Thu Feb 04, 2021 9:41 am

OTHER MPI ERROR while execution

#1 Post by pankaj_srivastava1 » Sun Nov 20, 2022 2:16 pm

We have a two node cluster in our lab and it is running on Centos 7.9 version. I have installed intel oneapi basic +hpc cluster edition. I have successfully compiled the VASP code also. However, I can't run any calculations. It is showing 'OTHER MPI ERROR' message. Any suggestion or clue regarding the issue would be greatly appreciated.

#My command and error message:
user@system: mpirun -np 4 ~/PATH_TO_VASP_FOLDER/bin/vasp_std

Abort(1090959) on node 0 (rank 0 in comm 0): Fatal error in PMPI_Init: Other MPI error, error stack:
MPIR_Init_thread(176)........:
MPID_Init(1538)..............:
MPIDI_OFI_mpi_init_hook(1473):
(unknown)(): Other MPI error
Abort(1090959) on node 0 (rank 0 in comm 0): Fatal error in PMPI_Init: Other MPI error, error stack:
MPIR_Init_thread(176)........:
MPID_Init(1538)..............:
MPIDI_OFI_mpi_init_hook(1473):
(unknown)(): Other MPI error

henrique_miranda
Global Moderator
Global Moderator
Posts: 345
Joined: Mon Nov 04, 2019 12:41 pm
Contact:

Re: OTHER MPI ERROR while execution

#2 Post by henrique_miranda » Mon Nov 21, 2022 8:04 am

This seems to be a problem with your MPI installation or configuration and not with VASP.
Have you tried running on a single node? Does it work then?

Post Reply