Installation error

Questions regarding the compilation of VASP on various platforms: hardware, compilers and libraries, etc.

Moderators: Global Moderator, Moderator

Post Reply
Message
Author
aniket_singha
Newbie
Newbie
Posts: 3
Joined: Fri Dec 18, 2020 1:23 pm

Installation error

#1 Post by aniket_singha » Mon Dec 21, 2020 11:23 am

Hello Sir,
I am getting Installation error. I am attaching compressed file including pre-compilation code and error.
You do not have the required permissions to view the files attached to this post.

martin.schlipf
Global Moderator
Global Moderator
Posts: 118
Joined: Fri Nov 08, 2019 7:18 am

Re: Installation error

#2 Post by martin.schlipf » Mon Dec 21, 2020 12:50 pm

I looked at your output and you seem to have a linking error with the LAPACK routines. I noticed that your makefile.include looks quite different from the ones that we provide on our website wiki/index.php/Installing_VASP.6.X.X#Ar ... lude_files
Could you tell me which one you based your installation upon?

Also which operating system do you use? Is it your own machine or a cluster/HPC resource? Do you know whether the library paths are set up properly?

aniket_singha
Newbie
Newbie
Posts: 3
Joined: Fri Dec 18, 2020 1:23 pm

Re: Installation error

#3 Post by aniket_singha » Mon Dec 21, 2020 5:47 pm

Hello sir,
"wiki/index.php/Installing_VASP.6.X.X#Ar ... lude_files" This makefile.include for gnu is there and it's same as the one we get when we use gedit makefile.include. I am using an ubuntu system so I used the modified variables in makefile.include provided in "wiki/index.php/A_Ubuntu_based_installation_of_VASP" file. Please guide through

Could you tell me which one you based your installation upon?
wiki/index.php/Makefile.include.linux_gnu

Also which operating system do you use?
Ubuntu 16.04 LTS

Is it your own machine or a cluster/HPC resource
It's a name_server
Memory: 754.6GiB
Processor: Intel Xeon(R) Gold 6252 CPU @2.10GHz *45
Graphics: Quadro RTX 6000/PCIe/SSE2
OS Type: 64 Bit
Disk: 12.3 TB

Do you know whether the library paths are set up properly
The libraries are installed at "/home/isird" thats the base path so I kept the path as default mentioned in makefile.include
"LIBDIR = /usr/lib/x86_64-linux-gnu" this path is correct

martin.schlipf
Global Moderator
Global Moderator
Posts: 118
Joined: Fri Nov 08, 2019 7:18 am

Re: Installation error

#4 Post by martin.schlipf » Tue Dec 22, 2020 8:21 am

Seeing your specifications it seems you're are trying to compile the wrong version of the code. It seems you have access to a superb graphics card, but want to compile the version that does not make use of it. Furthermore, even if you for some reason do not want to use the GPU, you still have an Intel machine so using the Intel MKL will be beneficial to your performance.

If you want to use the GPU version, I would kindly ask you to wait for a few days. There is a new release of VASP coming up soon, which will greatly enhance the performance on GPUs. If you want to proceed without GPU support, please let me know whether you want to continue using the GNU software or if you want to try the Intel MKL route instead (see here for a instruction how to obtain the latter).

aniket_singha
Newbie
Newbie
Posts: 3
Joined: Fri Dec 18, 2020 1:23 pm

Further information

#5 Post by aniket_singha » Thu Dec 24, 2020 5:27 pm

Hello Sir,
"if you want to try the Intel MKL route instead (see here for a instruction how to obtain the latter)."
This is extension of previous message. I created the intel repository as per guideline. I installed various intel libraries. I am providing file with the code but I am getting error at "make libintel64". Error file and the code are attached . Please find the attachment and guide me further.
You do not have the required permissions to view the files attached to this post.

martin.schlipf
Global Moderator
Global Moderator
Posts: 118
Joined: Fri Nov 08, 2019 7:18 am

Re: Installation error

#6 Post by martin.schlipf » Mon Jan 04, 2021 8:03 am

Sorry we cannot provide support for installing the Intel toolchain, please contact Intel if you have trouble with their products. But at a quick glance, I can see that you want to use the intel compilers to compile the libraries, which are probably not available on your machine (or at least they are not in your PATH variable). Please check where the intel compiler is found or set up the library to use gcc/gfortran instead.

Post Reply